GHSA-4gh5-3hqj-x3pj

Suggest an improvement
Source
https://github.com/advisories/GHSA-4gh5-3hqj-x3pj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-4gh5-3hqj-x3pj/GHSA-4gh5-3hqj-x3pj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-4gh5-3hqj-x3pj
Aliases
Published
2022-05-17T03:57:19Z
Modified
2024-04-23T22:41:48.229257Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Drupal Form API ignores access restrictions on submit buttons
Details

The Form API in Drupal 6.x before 6.38 ignores access restrictions on submit buttons, which might allow remote attackers to bypass intended access restrictions by leveraging permission to submit a form with a button that has "#access" set to FALSE in the server-side form definition.

References

Affected packages

Packagist / drupal/core

Package

Name
drupal/core
Purl
pkg:composer/drupal/core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.0
Fixed
6.38

Packagist / drupal/drupal

Package

Name
drupal/drupal
Purl
pkg:composer/drupal/drupal

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.0
Fixed
6.38