GHSA-4hjj-9gp7-4frg

Suggest an improvement
Source
https://github.com/advisories/GHSA-4hjj-9gp7-4frg
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/10/GHSA-4hjj-9gp7-4frg/GHSA-4hjj-9gp7-4frg.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-4hjj-9gp7-4frg
Aliases
  • CVE-2022-43405
Published
2022-10-19T19:00:21Z
Modified
2023-11-08T04:10:42.165087Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Sandbox bypass vulnerability in Jenkins Pipeline: Groovy Libraries Plugin and Pipeline: Deprecated Groovy Libraries Plugin
Details

Pipeline: Groovy Libraries Plugin and older releases of the Pipeline: Deprecated Groovy Libraries Plugin (formerly Pipeline: Shared Groovy Libraries Plugin) define the library Pipeline step, which allows Pipeline authors to dynamically load Pipeline libraries. The return value of this step can be used to instantiate classes defined in the loaded library.

In Pipeline: Groovy Libraries Plugin 612.v84da9c54906d and earlier and in Pipeline: Deprecated Groovy Libraries Plugin 583.vf3b454e43966 and earlier, the library step can be used to invoke sandbox-generated synthetic constructors in crafted untrusted libraries and construct any subclassable type. This is similar to SECURITY-582 in the 2017-08-07 security advisory, but in a different plugin.

This vulnerability allows attackers with permission to define untrusted Pipeline libraries and to define and run sandboxed Pipelines, to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.

Pipeline: Groovy Libraries Plugin 613.v9c41a_160233f rejects improper calls to sandbox-generated synthetic constructors when using the library step.

Pipeline: Deprecated Groovy Libraries Plugin 588.v576c103a_ff86 no longer contains the library step. It has been moved into the Pipeline: Groovy Libraries Plugin.

References

Affected packages

Maven / io.jenkins.plugins:pipeline-groovy-lib

Package

Name
io.jenkins.plugins:pipeline-groovy-lib
View open source insights on deps.dev
Purl
pkg:maven/io.jenkins.plugins/pipeline-groovy-lib

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
613.v9c41a_160233f

Affected versions

589.*

589.vb_a_b_4a_a_8c443c

591.*

591.v3a_7f422b_d058

593.*

593.va_a_fc25d520e9
593.595.vfc6485d13dcd

598.*

598.vcd66b_a_336510

612.*

612.v84da_9c54906d
612.614.v48dcb_f62a_640

Database specific

{
    "last_known_affected_version_range": "< 613.v9c41a"
}

Maven / org.jenkins-ci.plugins.workflow:workflow-cps-global-lib

Package

Name
org.jenkins-ci.plugins.workflow:workflow-cps-global-lib
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins.workflow/workflow-cps-global-lib

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
588.v576c103a_ff86

Affected versions

0.*

0.1-beta-5
0.1-beta-6
0.1-beta-7
0.1-beta-8

1.*

1.0-beta-1
1.0
1.1
1.2
1.3
1.4
1.4.1
1.4.2
1.4.3-beta-1
1.4.3
1.5
1.6-alpha-1
1.6
1.7-alpha-1
1.7
1.8
1.9-beta-1
1.9
1.10-beta-1
1.10
1.10.1
1.11-beta-1
1.11-beta-2
1.11-beta-3
1.11-beta-4
1.11
1.12-beta-1
1.12-beta-2
1.12-beta-3
1.12
1.13
1.14-beta-1
1.14
1.14.1-beta-1
1.14.1
1.14.2
1.15-beta-1
1.15

2.*

2.0
2.1
2.2
2.3
2.4
2.5
2.6
2.7
2.8
2.9
2.10
2.11
2.12
2.12.1
2.13
2.13.1
2.14
2.15
2.16
2.17
2.18
2.18.1
2.19
2.20
2.21
2.21.1
2.21.3

544.*

544.vff04fa68714d

545.*

545.v7b28cce323cf

548.*

548.v9085a486966a

552.*

552.vd9cc05b8a2e1
552.554.vdba55efb9e88

561.*

561.va_ce0de3c2d69

564.*

564.ve62a_4eb_b_e039

566.*

566.vd0a_a_3334a_555

570.*

570.v21311f4951f8

575.*

575.v24fa_0a_b_f7383

581.*

581.ve633085a_8a_87

583.*

583.vf3b_454e43966

Database specific

{
    "last_known_affected_version_range": "<= 583.vf3b"
}