GHSA-4j9x-g4x8-vcmf

Suggest an improvement
Source
https://github.com/advisories/GHSA-4j9x-g4x8-vcmf
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/06/GHSA-4j9x-g4x8-vcmf/GHSA-4j9x-g4x8-vcmf.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-4j9x-g4x8-vcmf
Published
2024-06-07T21:15:56Z
Modified
2024-06-07T21:31:14.922189Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
ZendFramework potential XML eXternal Entity injection vectors
Details

Zend_Feed_Rss and Zend_Feed_Atom were found to contain potential XML eXternal Entity (XXE) vectors due to insecure usage of PHP's DOM extension. External entities could be specified by adding a specific DOCTYPE element to feeds; exploiting this vulnerability could coerce opening arbitrary files and/or TCP connections.

A similar issue was fixed for 1.11.13 and 1.12.0, in the Zend_Feed::import() factory method; however, the reporter of the issue discovered that the individual classes contained similar functionality in their constructors which remained vulnerable.

References

Affected packages

Packagist / zendframework/zendframework1

Package

Name
zendframework/zendframework1
Purl
pkg:composer/zendframework/zendframework1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.11.0
Fixed
1.11.15

Packagist / zendframework/zendframework1

Package

Name
zendframework/zendframework1
Purl
pkg:composer/zendframework/zendframework1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.12.0
Fixed
1.12.1

Affected versions

1.*

1.12.0