GHSA-4rvg-955w-h68q

Suggest an improvement
Source
https://github.com/advisories/GHSA-4rvg-955w-h68q
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/07/GHSA-4rvg-955w-h68q/GHSA-4rvg-955w-h68q.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-4rvg-955w-h68q
Aliases
  • CVE-2018-3713
Published
2018-07-26T14:47:40Z
Modified
2023-11-08T04:00:16.690168Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Path Traversal in angular-http-server
Details

Affected versions of angular-http-server are vulnerable to path traversal allowing a remote attacker to read files from the server that uses angular-http-server.

Recommendation

Update to version 1.6.0 or later.

:exclamation: Note: This was originally thought to be fixed in version 1.4.3, though according to this issue the vulnerability was not completely fixed until version 1.6.0.

References

Affected packages

npm / angular-http-server

Package

Name
angular-http-server
View open source insights on deps.dev
Purl
pkg:npm/angular-http-server

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.0