GHSA-4w4p-xwrr-9crh

Suggest an improvement
Source
https://github.com/advisories/GHSA-4w4p-xwrr-9crh
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/06/GHSA-4w4p-xwrr-9crh/GHSA-4w4p-xwrr-9crh.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-4w4p-xwrr-9crh
Aliases
Published
2021-06-16T17:18:49Z
Modified
2023-11-08T04:02:47.430124Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Injection in Apache Syncope
Details

Vulnerability to Server-Side Template Injection on Mail templates for Apache Syncope 2.0.X releases prior to 2.0.15, 2.1.X releases prior to 2.1.6, enabling attackers to inject arbitrary JEXL expressions, leading to Remote Code Execution (RCE) was discovered.

References

Affected packages

Maven / org.apache.syncope:syncope-core

Package

Name
org.apache.syncope:syncope-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.syncope/syncope-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.0.0
Fixed
2.0.15

Affected versions

2.*

2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.0.7
2.0.8
2.0.9
2.0.10
2.0.11
2.0.12
2.0.13
2.0.14

Maven / org.apache.syncope:syncope-core

Package

Name
org.apache.syncope:syncope-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.syncope/syncope-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.1.0
Fixed
2.1.6

Affected versions

2.*

2.1.0
2.1.1
2.1.2
2.1.3
2.1.4
2.1.5