GHSA-4wf5-vphf-c2xc

Suggest an improvement
Source
https://github.com/advisories/GHSA-4wf5-vphf-c2xc
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-4wf5-vphf-c2xc/GHSA-4wf5-vphf-c2xc.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-4wf5-vphf-c2xc
Aliases
  • CVE-2022-25858
  • SNYK-JAVA-ORGWEBJARSNPM-2949722
  • SNYK-JS-TERSER-2806366
Published
2022-07-16T00:00:20Z
Modified
2023-11-08T04:08:49.629638Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Terser insecure use of regular expressions leads to ReDoS
Details

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

References

Affected packages

npm / terser

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.8.1

npm / terser

Package

Affected ranges

Type
SEMVER
Events
Introduced
5.0.0
Fixed
5.14.2