GHSA-52xf-5p2m-9wrv

Suggest an improvement
Source
https://github.com/advisories/GHSA-52xf-5p2m-9wrv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/06/GHSA-52xf-5p2m-9wrv/GHSA-52xf-5p2m-9wrv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-52xf-5p2m-9wrv
Published
2024-06-06T14:26:18Z
Modified
2024-06-06T14:26:18Z
Summary
s2n-tls has a potentially observable differences in RSA premaster secret handling
Details

When receiving a message from a client that sent an invalid RSA premaster secret, an issue in s2n-tls results in the server performing additional processing when the premaster secret contains an incorrect client hello version. While no practical attack on s2n-tls has been demonstrated, this causes a small timing difference which could theoretically be used as described in the Marvin Attack [1].

We would like to thank Hubert Kario [2] for reporting this issue.

Impact

The extent of this issue is a timing difference. No practical attack on s2n-tls has been demonstrated.

This issue affects server applications that permit RSA key exchange. Applications that use the default, built-in blinding feature or properly implement self-service blinding are not affected.

Impacted versions: <= v1.4.15.

Patches

The patch is included in v1.4.16 [3].

Workarounds

Applications can work around this issue by using an s2n-tls security policy that disallows RSA key exchange.

If you have any questions or comments about this advisory we ask that you contact AWS/Amazon Security via our vulnerability reporting page [4] or directly via email to aws-security@amazon.com. Please do not create a public GitHub issue.

[1] https://people.redhat.com/~hkario/marvin/ [2] https://github.com/tomato42 [3] https://github.com/aws/s2n-tls/releases/tag/v1.4.16 [4] https://aws.amazon.com/security/vulnerability-reporting

References

Affected packages

crates.io / s2n-tls

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.2.7

Database specific

{
    "last_known_affected_version_range": "<= 0.2.6"
}