GHSA-562c-5r94-xh97

Suggest an improvement
Source
https://github.com/advisories/GHSA-562c-5r94-xh97
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/08/GHSA-562c-5r94-xh97/GHSA-562c-5r94-xh97.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-562c-5r94-xh97
Aliases
Published
2018-08-23T19:10:40Z
Modified
2024-02-22T05:31:38.513919Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Flask is vulnerable to Denial of Service via incorrect encoding of JSON data
Details

The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3.

References

Affected packages

PyPI / flask

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.12.3

Affected versions

0.*

0.1
0.2
0.3
0.3.1
0.4
0.5
0.5.1
0.5.2
0.6
0.6.1
0.7
0.7.1
0.7.2
0.8
0.8.1
0.9
0.10
0.10.1
0.11
0.11.1
0.12
0.12.1
0.12.2

Ecosystem specific

{
    "affected_functions": [
        "flask.json.loads",
        "flask.wrappers.Request.get_json"
    ]
}