GHSA-595j-wpfg-23w4

Suggest an improvement
Source
https://github.com/advisories/GHSA-595j-wpfg-23w4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-595j-wpfg-23w4/GHSA-595j-wpfg-23w4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-595j-wpfg-23w4
Aliases
Published
2022-05-14T03:46:13Z
Modified
2024-02-16T07:56:55.407113Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Moodle XSS Vulnerability
Details

In Moodle 3.x, there is XSS via a calendar event name.

References

Affected packages

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.3
Fixed
3.3.4

Affected versions

v3.*

v3.3.0-beta
v3.3.0-rc1
v3.3.0-rc2
v3.3.0-rc3
v3.3.0
v3.3.1
v3.3.2
v3.3.3

Database specific

{
    "last_known_affected_version_range": "<= 3.3.3"
}

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.2
Fixed
3.2.7

Affected versions

v3.*

v3.2.0-beta
v3.2.0-rc1
v3.2.0-rc2
v3.2.0-rc3
v3.2.0-rc4
v3.2.0-rc5
v3.2.0
v3.2.1
v3.2.2
v3.2.3
v3.2.4
v3.2.5
v3.2.6

Database specific

{
    "last_known_affected_version_range": "<= 3.2.6"
}

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.1
Fixed
3.1.10

Affected versions

v3.*

v3.1.0-beta
v3.1.0-rc1
v3.1.0-rc2
v3.1.0
v3.1.1
v3.1.2
v3.1.3
v3.1.4
v3.1.5
v3.1.6
v3.1.7
v3.1.8
v3.1.9

Database specific

{
    "last_known_affected_version_range": "<= 3.1.9"
}