GHSA-5cv4-48h7-7782

Suggest an improvement
Source
https://github.com/advisories/GHSA-5cv4-48h7-7782
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/08/GHSA-5cv4-48h7-7782/GHSA-5cv4-48h7-7782.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-5cv4-48h7-7782
Aliases
Published
2023-08-17T06:30:13Z
Modified
2024-02-16T08:02:50.591160Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H CVSS Calculator
Summary
Cockpit Cross-site Scripting vulnerability
Details

Cross-site Scripting (XSS) - Stored in GitHub repository cockpit-hq/cockpit 2.6.3 and prior. A patch is available at commit 36d1d4d256cbbab028342ba10cc493e5c119172c and anticipated to be part of version 2.6.4.

References

Affected packages

Packagist / cockpit-hq/cockpit

Package

Name
cockpit-hq/cockpit
Purl
pkg:composer/cockpit-hq/cockpit

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
2.6.3

Affected versions

2.*

2.0.0
2.0.1
2.0.2
2.1.0
2.1.1
2.1.2
2.2.0
2.2.1
2.2.2
2.3.0
2.3.1
2.3.2
2.3.3
2.3.4
2.3.5
2.3.6
2.3.7
2.3.8
2.3.9
2.4.0
2.4.1
2.5.0
2.5.1
2.5.2
2.6.0
2.6.1
2.6.2
2.6.3