GHSA-5g4r-2qhx-vqfm

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-5g4r-2qhx-vqfm/GHSA-5g4r-2qhx-vqfm.json
Aliases
  • CVE-2022-31026
Published
2022-06-06T21:22:05Z
Modified
2022-06-15T20:25:38.848641Z
Details

Impact

When authenticating, a malicious server could return a specially crafted authentication packet, causing the client to read and return up to 12 bytes of data from an uninitialized variable in stack memory.

Patches

Users of the trilogy gem should upgrade to version 2.1.1

Workarounds

This issue can be avoided by only connecting to trusted servers.

Acknowledgements

We would like to thank Sergei Volokitin for reporting this vulnerability

For more information

If you have any questions or comments about this advisory: * Open an issue in trilogy

References

Affected packages

RubyGems / trilogy

trilogy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
2.1.1

Affected versions

2.*

2.0.0
2.1.0