GHSA-5ghg-233h-7j79

Suggest an improvement
Source
https://github.com/advisories/GHSA-5ghg-233h-7j79
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-5ghg-233h-7j79/GHSA-5ghg-233h-7j79.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-5ghg-233h-7j79
Aliases
Published
2022-05-24T16:46:57Z
Modified
2024-02-16T08:23:57.409572Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
PyDio Stored XSS Vulnerability
Details

A stored XSS vulnerability exists in the web application of Pydio through 8.2.2 that can be exploited by levering the file upload and file preview features of the application. An authenticated attacker can upload an HTML file containing JavaScript code and afterwards a file preview URL can be used to access the uploaded file. If a malicious user shares an uploaded HTML file containing JavaScript code with another user of the application, and tricks an authenticated victim into accessing a URL that results in the HTML code being interpreted by the web browser, then the included JavaScript code is executed under the context of the victim user session.

References

Affected packages

PyPI / pydio

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
8.2.2

Affected versions

0.*

0.1.0rc3
0.1.0rc4
0.1.0
0.2.0
0.2.1
0.3.3
0.4.0
0.4.1