GHSA-5v2j-w677-j4mp

Suggest an improvement
Source
https://github.com/advisories/GHSA-5v2j-w677-j4mp
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-5v2j-w677-j4mp/GHSA-5v2j-w677-j4mp.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-5v2j-w677-j4mp
Aliases
  • CVE-2019-1003027
Published
2022-05-13T01:31:34Z
Modified
2024-02-16T08:14:15.012885Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
SSRF vulnerability due to missing permission check in Jenkins OctopusDeploy Plugin
Details

A server-side request forgery vulnerability exists in Jenkins OctopusDeploy Plugin 1.8.1 and earlier in OctopusDeployPlugin.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified URL and obtain the HTTP response code if successful, and exception error message otherwise.

References

Affected packages

Maven / hudson.plugins.octopusdeploy:octopusdeploy

Package

Name
hudson.plugins.octopusdeploy:octopusdeploy
View open source insights on deps.dev
Purl
pkg:maven/hudson.plugins.octopusdeploy/octopusdeploy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.9.0

Affected versions

1.*

1.3.0
1.3.1
1.3.2
1.4.0
1.5.0
1.6.0
1.7.0
1.7.1
1.8.0
1.8.1

Database specific

{
    "last_known_affected_version_range": "<= 1.8.1"
}