GHSA-5xf9-3v63-ww6f

Suggest an improvement
Source
https://github.com/advisories/GHSA-5xf9-3v63-ww6f
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-5xf9-3v63-ww6f/GHSA-5xf9-3v63-ww6f.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-5xf9-3v63-ww6f
Aliases
  • CVE-2014-0110
Published
2022-05-13T01:09:20Z
Modified
2023-12-21T22:05:31Z
Summary
Uncontrolled Resource Consumption in Apache CXF
Details

Apache CXF before 2.6.14 and 2.7.x before 2.7.11 allows remote attackers to cause a denial of service (/tmp disk consumption) via a large invalid SOAP message.

References

Affected packages

Maven / org.apache.cxf:cxf-core

Package

Name
org.apache.cxf:cxf-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.cxf/cxf-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.14

Maven / org.apache.cxf:cxf-core

Package

Name
org.apache.cxf:cxf-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.cxf/cxf-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.7.0
Fixed
2.7.11