GHSA-5xqm-hc45-f2g2

Suggest an improvement
Source
https://github.com/advisories/GHSA-5xqm-hc45-f2g2
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/11/GHSA-5xqm-hc45-f2g2/GHSA-5xqm-hc45-f2g2.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-5xqm-hc45-f2g2
Aliases
  • CVE-2021-37942
Published
2023-11-22T03:30:19Z
Modified
2024-02-16T08:08:14.257250Z
Severity
  • 7.0 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
APM Java Agent Local Privilege Escalation issue
Details

A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious plugin to an application running the APM Java agent. By using this vulnerability, an attacker could execute code at a potentially higher level of permissions than their user typically has access to.

References

Affected packages

Maven / co.elastic.apm:apm-agent-parent

Package

Name
co.elastic.apm:apm-agent-parent
View open source insights on deps.dev
Purl
pkg:maven/co.elastic.apm/apm-agent-parent

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.18.0
Fixed
1.27.1

Affected versions

1.*

1.18.0
1.18.1
1.19.0
1.20.0
1.21.0
1.22.0
1.23.0
1.24.0
1.25.0
1.26.0
1.26.1
1.26.2
1.27.0