GHSA-5xvc-vgmp-jgc3

Suggest an improvement
Source
https://github.com/advisories/GHSA-5xvc-vgmp-jgc3
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/10/GHSA-5xvc-vgmp-jgc3/GHSA-5xvc-vgmp-jgc3.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-5xvc-vgmp-jgc3
Aliases
Published
2021-10-28T23:13:57Z
Modified
2024-02-16T07:53:16.988622Z
Severity
  • 9.1 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS Calculator
Summary
Improper Access Control in jupyterhub-firstuseauthenticator
Details

Impact

When JupyterHub is used with FirstUseAuthenticator, the vulnerability allows unauthorized access to any user's account if create_users=True and the username is known or guessed.

Patches

Upgrade to jupyterhub-firstuseauthenticator to 1.0, or apply patch https://github.com/jupyterhub/firstuseauthenticator/pull/38.patch

Workarounds

If you cannot upgrade, there is no complete workaround, but it can be mitigated.

If you cannot upgrade yet, you can disable user creation with c.FirstUseAuthenticator.create_users = False, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until you can patch or upgrade.

References

Affected packages

PyPI / jupyterhub-firstuseauthenticator

Package

Name
jupyterhub-firstuseauthenticator
View open source insights on deps.dev
Purl
pkg:pypi/jupyterhub-firstuseauthenticator

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.0

Affected versions

0.*

0.9
0.10
0.11
0.12
0.13.0
0.14.0
0.14.1

Ecosystem specific

{
    "affected_functions": [
        "firstuseauthenticator.firstuseauthenticator.FirstUseAuthenticator.authenticate"
    ]
}