GHSA-63f2-6959-2pxj

Suggest an improvement
Source
https://github.com/advisories/GHSA-63f2-6959-2pxj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/03/GHSA-63f2-6959-2pxj/GHSA-63f2-6959-2pxj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-63f2-6959-2pxj
Aliases
Published
2023-03-31T12:30:16Z
Modified
2023-12-06T01:02:47.962688Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Mattermost vulnerable to cross-site scripting (XSS)
Details

Boards in Mattermost allows an attacker to upload a malicious SVG image file as an attachment to a card and share it using a direct link to the file.

Issue Identifier: MMSA-2023-00139

References

Affected packages

Go / github.com/mattermost/mattermost-server/v6

Package

Name
github.com/mattermost/mattermost-server/v6
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost-server/v6

Affected ranges

Type
SEMVER
Events
Introduced
6.0.0
Fixed
7.1.6

Database specific

{
    "last_known_affected_version_range": "<= 6.7.2"
}

Go / github.com/mattermost/mattermost-server

Package

Name
github.com/mattermost/mattermost-server
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost-server

Affected ranges

Type
SEMVER
Events
Introduced
7.7.0
Fixed
7.7.2

Database specific

{
    "last_known_affected_version_range": "<= 7.7.1"
}

Go / github.com/mattermost/mattermost-server

Package

Name
github.com/mattermost/mattermost-server
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost-server

Affected ranges

Type
SEMVER
Events
Introduced
7.1.0
Fixed
7.1.6

Database specific

{
    "last_known_affected_version_range": "<= 7.1.5"
}

Go / github.com/mattermost/mattermost-server

Package

Name
github.com/mattermost/mattermost-server
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost-server

Affected ranges

Type
SEMVER
Events
Introduced
7.8.0
Fixed
7.8.1

Affected versions

7.*

7.8.0

Go / github.com/mattermost/mattermost-server/v5

Package

Name
github.com/mattermost/mattermost-server/v5
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost-server/v5

Affected ranges

Type
SEMVER
Events
Introduced
5.0.0
Fixed
7.1.6

Database specific

{
    "last_known_affected_version_range": "<= 5.39.3"
}

Go / github.com/mattermost/mattermost-server/v6

Package

Name
github.com/mattermost/mattermost-server/v6
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost-server/v6

Affected ranges

Type
SEMVER
Events
Introduced
3.3.0
Fixed
7.1.6

Database specific

{
    "last_known_affected_version_range": "<= 4.10.10"
}