GHSA-649c-x44h-4q7v

Suggest an improvement
Source
https://github.com/advisories/GHSA-649c-x44h-4q7v
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/02/GHSA-649c-x44h-4q7v/GHSA-649c-x44h-4q7v.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-649c-x44h-4q7v
Aliases
  • CVE-2018-16480
Published
2019-02-07T18:14:37Z
Modified
2023-11-08T04:00:00.374827Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Tnantoka/public XSS Vulnerability
Details

A XSS vulnerability was found in module public <0.1.4 that allows malicious Javascript code to run in the browser, due to the absence of sanitization of the file/folder names before rendering.

References

Affected packages

npm / public

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.1.4