GHSA-66j8-c83m-gj5f

Suggest an improvement
Source
https://github.com/advisories/GHSA-66j8-c83m-gj5f
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/04/GHSA-66j8-c83m-gj5f/GHSA-66j8-c83m-gj5f.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-66j8-c83m-gj5f
Aliases
  • CVE-2024-31864
Published
2024-04-09T18:30:22Z
Modified
2024-05-02T19:17:18.841461Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Apache Zeppelin remote code execution by adding malicious JDBC connection string
Details

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin.

The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1.

Users are recommended to upgrade to version 0.11.1, which fixes the issue.

References

Affected packages

Maven / org.apache.zeppelin:zeppelin-jdbc

Package

Name
org.apache.zeppelin:zeppelin-jdbc
View open source insights on deps.dev
Purl
pkg:maven/org.apache.zeppelin/zeppelin-jdbc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.11.1

Affected versions

0.*

0.6.0
0.6.1
0.6.2
0.7.0
0.7.1
0.7.2
0.7.3
0.8.0
0.8.1
0.8.2
0.9.0
0.9.0-preview1
0.9.0-preview2
0.10.0
0.10.1
0.11.0