GHSA-66xp-28cq-mrf2

Suggest an improvement
Source
https://github.com/advisories/GHSA-66xp-28cq-mrf2
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-66xp-28cq-mrf2/GHSA-66xp-28cq-mrf2.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-66xp-28cq-mrf2
Aliases
Published
2022-05-24T17:35:32Z
Modified
2024-04-23T23:11:27.022181Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Moodle Denial of Service
Details

A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

References

Affected packages

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.9
Fixed
3.9.2

Affected versions

v3.*

v3.9.0-beta
v3.9.0-rc1
v3.9.0-rc2
v3.9.0-rc3
v3.9.0
v3.9.1

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.8
Fixed
3.8.5

Affected versions

v3.*

v3.8.0-beta
v3.8.0-rc1
v3.8.0
v3.8.1
v3.8.2
v3.8.3
v3.8.4

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.7
Fixed
3.7.8

Affected versions

v3.*

v3.7.0-beta
v3.7.0-rc1
v3.7.0-rc2
v3.7.0
v3.7.1
v3.7.2
v3.7.3
v3.7.4
v3.7.5
v3.7.6
v3.7.7

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.5
Fixed
3.5.14

Affected versions

v3.*

v3.5.0-beta
v3.5.0-rc1
v3.5.0
v3.5.1
v3.5.2
v3.5.3
v3.5.4
v3.5.5
v3.5.6
v3.5.7
v3.5.8
v3.5.9
v3.5.10
v3.5.11
v3.5.12
v3.5.13