GHSA-67mx-jc2f-jgjm

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-67mx-jc2f-jgjm/GHSA-67mx-jc2f-jgjm.json
Aliases
  • CVE-2022-1986
Published
2022-06-08T22:34:21Z
Modified
2022-06-17T19:21:46Z
Details

Impact

The malicious user is able to update a crafted config file into repository's .git directory in combination with crafted file deletion to gain SSH access to the server. All installations with repository upload enabled (default) are affected.

Patches

File deletions are prohibited to repository's .git directory. Users should upgrade to 0.12.9 or the latest 0.13.0+dev.

Workarounds

N/A

References

https://huntr.dev/bounties/776e8f29-ff5e-4501-bb9f-0bd335007930/

For more information

If you have any questions or comments about this advisory, please post on #7000.

References

Affected packages

Go / gogs.io/gogs

gogs.io/gogs

Affected ranges

Type
SEMVER
Events
Introduced
0
Fixed
0.12.9

Affected versions