GHSA-6927-3vr9-fxf2

Source
https://github.com/advisories/GHSA-6927-3vr9-fxf2
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/03/GHSA-6927-3vr9-fxf2/GHSA-6927-3vr9-fxf2.json
Aliases
Published
2024-03-01T20:08:23Z
Modified
2024-04-01T07:26:45.864663Z
Summary
ZDI-CAN-19105: Parse Server literalizeRegexPart SQL Injection
Details

Impact

This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database.

Patches

The algorithm to detect SQL injection has been improved.

Workarounds

None.

References

  • https://github.com/parse-community/parse-server/security/advisories/GHSA-6927-3vr9-fxf2
  • https://github.com/parse-community/parse-server/releases/tag/6.5.0 (fixed in Parse Server 6)
  • https://github.com/parse-community/parse-server/releases/tag/7.0.0-alpha.20 (fixed in Parse Server 7 alpha release)

Credits

  • Mikhail Shcherbakov (https://twitter.com/yu5k3) working with Trend Micro Zero Day Initiative (finder)
  • Ehsan Persania (remediation developer)
  • Manuel Trezza (coordinator)
References

Affected packages

npm / parse-server

Package

Affected ranges

Type
SEMVER
Events
Introduced
0The exact introduced commit is unknown
Fixed
6.5.0

npm / parse-server

Package

Affected ranges

Type
SEMVER
Events
Introduced
7.0.0-alpha.1
Fixed
7.0.0-alpha.20