GHSA-6jvm-3j5h-79f6

Suggest an improvement
Source
https://github.com/advisories/GHSA-6jvm-3j5h-79f6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2017/10/GHSA-6jvm-3j5h-79f6/GHSA-6jvm-3j5h-79f6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-6jvm-3j5h-79f6
Aliases
  • CVE-2015-2963
Published
2017-10-24T18:33:36Z
Modified
2023-11-08T03:57:52.662807Z
Summary
paperclip Cross-site Scripting vulnerability
Details

The thoughtbot paperclip gem before 4.2.2 for Ruby does not consider the content-type value during media-type validation, which allows remote attackers to upload HTML documents and conduct cross-site scripting (XSS) attacks via a spoofed value, as demonstrated by image/jpeg.

References

Affected packages

RubyGems / paperclip

Package

Name
paperclip
Purl
pkg:gem/paperclip

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.2.2

Affected versions

2.*

2.1.0
2.1.2
2.1.5
2.2.0
2.2.1
2.2.2
2.2.3
2.2.4
2.2.5
2.2.6
2.2.7
2.2.8
2.2.9.1
2.2.9.2
2.3.0
2.3.1
2.3.1.1
2.3.2
2.3.3
2.3.4
2.3.5
2.3.6
2.3.7
2.3.8
2.3.9
2.3.10
2.3.11
2.3.12
2.3.15
2.3.16
2.4.0
2.4.1
2.4.2
2.4.3
2.4.4
2.4.5
2.5.0
2.5.1
2.5.2
2.6.0
2.7.0
2.7.1
2.7.2
2.7.4
2.7.5
2.8.0

3.*

3.0.2
3.0.3
3.0.4
3.1.0
3.1.1
3.1.2
3.1.4
3.2.0
3.2.1
3.3.0
3.3.1
3.4.0
3.4.1
3.4.2
3.5.0
3.5.1
3.5.2
3.5.3
3.5.4

4.*

4.0.0
4.1.0
4.1.1
4.2.0
4.2.1