GHSA-6phf-73q6-gh87

Suggest an improvement
Source
https://github.com/advisories/GHSA-6phf-73q6-gh87
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2020/06/GHSA-6phf-73q6-gh87/GHSA-6phf-73q6-gh87.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-6phf-73q6-gh87
Aliases
  • CVE-2019-10086
Related
Published
2020-06-15T20:36:17Z
Modified
2024-03-08T05:28:43.649817Z
Severity
  • 7.3 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L CVSS Calculator
Summary
Insecure Deserialization in Apache Commons Beanutils
Details

In Apache Commons Beanutils 1.9.2, a special BeanIntrospector class was added which allows suppressing the ability for an attacker to access the classloader via the class property available on all Java objects. We, however were not using this by default characteristic of the PropertyUtilsBean.

References

Affected packages

Maven / commons-beanutils:commons-beanutils

Package

Name
commons-beanutils:commons-beanutils
View open source insights on deps.dev
Purl
pkg:maven/commons-beanutils/commons-beanutils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.9.4

Affected versions

1.*

1.0
1.2
1.3
1.4
1.4.1
1.5
1.6
1.6.1
1.7.0
1.8.0-BETA
1.8.0
1.8.1
1.8.2
1.8.3
1.9.0
1.9.1
1.9.2
1.9.3