GHSA-6qj8-c27w-rp33

Suggest an improvement
Source
https://github.com/advisories/GHSA-6qj8-c27w-rp33
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/01/GHSA-6qj8-c27w-rp33/GHSA-6qj8-c27w-rp33.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-6qj8-c27w-rp33
Aliases
Published
2022-01-06T19:38:07Z
Modified
2023-11-08T04:01:24.189008Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Cross-site scripting in Apache Syncome EndUser
Details

It was found that the Apache Syncope EndUser UI login page prio to 2.0.15 and 2.1.6 reflects the successMessage parameters. By this mean, a user accessing the Enduser UI could execute javascript code from URL query string.

References

Affected packages

Maven / org.apache.syncope.client:syncope-client-enduser

Package

Name
org.apache.syncope.client:syncope-client-enduser
View open source insights on deps.dev
Purl
pkg:maven/org.apache.syncope.client/syncope-client-enduser

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.15

Affected versions

2.*

2.0.0-M1
2.0.0-M2
2.0.0-M3
2.0.0-M4
2.0.0.M5
2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.0.7
2.0.8
2.0.9
2.0.10
2.0.11
2.0.12
2.0.13
2.0.14

Maven / org.apache.syncope.client:syncope-client-enduser

Package

Name
org.apache.syncope.client:syncope-client-enduser
View open source insights on deps.dev
Purl
pkg:maven/org.apache.syncope.client/syncope-client-enduser

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.1.0
Fixed
2.1.6

Affected versions

2.*

2.1.0
2.1.1
2.1.2
2.1.3
2.1.4
2.1.5