GHSA-6qmx-42h2-j8h6

Suggest an improvement
Source
https://github.com/advisories/GHSA-6qmx-42h2-j8h6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/04/GHSA-6qmx-42h2-j8h6/GHSA-6qmx-42h2-j8h6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-6qmx-42h2-j8h6
Aliases
Published
2024-04-17T18:21:57Z
Modified
2024-06-04T10:56:50.570296Z
Severity
  • 7.3 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
.NET Elevation of Privilege Vulnerability
Details

Microsoft Security Advisory CVE-2024-21409 | .NET Elevation of Privilege Vulnerability

<a name="executive-summary"></a>Executive summary

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 7.0 ,and .NET 8.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.

A use-after-free vulnerability exists in WPF which may result in Elevation of Privilege when viewing untrusted documents. This is a Windows only vulnerability.

Announcement

Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/303

<a name="mitigation-factors"></a>Mitigation factors

This vulnerability affects only WPF-based applications.

<a name="affected-software"></a>Affected software

  • Any .NET 7.0 application running on .NET 6.0.28 or earlier.
  • Any .NET 7.0 application running on .NET 7.0.17 or earlier.
  • Any .NET 8.0 application running on .NET 8.0.3 or earlier.

<a name="affected-packages"></a>Affected Packages

The vulnerability affects any Microsoft .NET Core project if it uses any of affected packages versions listed below

<a name=".NET 7"></a>.NET 6.0

Package name | Affected version | Patched version ------------ | ---------------- | ------------------------- Microsoft.WindowsDesktop.App.Runtime.win-arm64 | < = 6.0.28 | 6.0.29 Microsoft.WindowsDesktop.App.Runtime.win-x64 | < = 6.0.28 | 6.0.29 Microsoft.WindowsDesktop.App.Runtime.win-x86 | < = 6.0.28 | 6.0.29

<a name=".NET 7"></a>.NET 7.0

Package name | Affected version | Patched version ------------ | ---------------- | ------------------------- Microsoft.WindowsDesktop.App.Runtime.win-arm64 | <= 7.0.17 | 7.0.18 Microsoft.WindowsDesktop.App.Runtime.win-x64 | <= 7.0.17 | 7.0.18 Microsoft.WindowsDesktop.App.Runtime.win-x86 | <= 7.0.17 | 7.0.18

<a name=".NET 7"></a>.NET 8.0

Package name | Affected version | Patched version ------------ | ---------------- | ------------------------- Microsoft.WindowsDesktop.App.Runtime.win-arm64 | <= 8.0.3 | 8.0.4 Microsoft.WindowsDesktop.App.Runtime.win-x64 | <= 8.0.3 | 8.0.4 Microsoft.WindowsDesktop.App.Runtime.win-x86 | <= 8.0.3 | 8.0.4

Advisory FAQ

<a name="how-affected"></a>How do I know if I am affected?

If you have a runtime or SDK with a version listed, or an affected package listed in affected software or affected packages, you're exposed to the vulnerability.

<a name="how-fix"></a>How do I fix the issue?

  • To fix the issue please install the latest version of .NET 8.0 or .NET 7.0 or .NET 6.0. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.
  • If you have .NET 6.0 or greater installed, you can list the versions you have installed by running the dotnet --info command. You will see output like the following;

    .NET Core SDK (reflecting any global.json):
    
    
     Version:   8.0.204
     Commit:    8473146e7d
    
    Runtime Environment:
    
     OS Name:     Windows
     OS Version:  10.0.18363
     OS Platform: Windows
     RID:         win10-x64
     Base Path:   C:\Program Files\dotnet\sdk\6.0.300\
    
    Host (useful for support):
    
      Version: 8.0.4
      Commit:  8473146e7d
    
    .NET Core SDKs installed:
    
      8.0.204 [C:\Program Files\dotnet\sdk]
    
    .NET Core runtimes installed:
    
      Microsoft.AspWindowsDesktop.App 8.0.4 [C:\Program Files\dotnet\shared\Microsoft.AspWindowsDesktop.App]
      Microsoft.WindowsDesktop.App 8.0.4 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]
      Microsoft.WindowsDesktop.App 8.0.4 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]
    
    
    To install additional .NET Core runtimes or SDKs:
      https://aka.ms/dotnet-download
    
  • If you're using .NET 8.0, you should download and install .NET 8.0.4 Runtime or .NET 8.0.204 SDK (for Visual Studio 2022 v17.8) from https://dotnet.microsoft.com/download/dotnet-core/8.0.

  • If you're using .NET 7.0, you should download and install Runtime 7.0.18 or SDK 7.0.118 (for Visual Studio 2022 v17.4) from https://dotnet.microsoft.com/download/dotnet-core/7.0.
  • If you're using .NET 6.0, you should download and install Runtime 6.0.29 or SDK 6.0.129 from https://dotnet.microsoft.com/download/dotnet-core/6.0.

.NET 6.0, .NET 7.0 and, .NET 8.0 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates.

Once you have installed the updated runtime or SDK, restart your apps for the update to take effect.

Additionally, if you've deployed self-contained applications targeting any of the impacted versions, these applications are also vulnerable and must be recompiled and redeployed.

Other Information

Reporting Security Issues

If you have found a potential security issue in .NET 8.0 or .NET 7.0 or .NET 6.0, please email details to secure@microsoft.com. Reports may qualify for the Microsoft .NET Core & .NET 5 Bounty. Details of the Microsoft .NET Bounty Program including terms and conditions are at https://aka.ms/corebounty.

Support

You can ask questions about this issue on GitHub in the .NET GitHub organization. The main repos are located at https://github.com/dotnet/runtime and https://github.com/dotnet/aspnet/. The Announcements repo (https://github.com/dotnet/Announcements) will contain this bulletin as an issue and will include a link to a discussion issue. You can ask questions in the linked discussion issue.

Disclaimer

The information provided in this advisory is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

External Links

CVE-2024-21409

Revisions

V1.0 (April 09, 2024): Advisory published.

Version 1.0

Last Updated 2024-04-09

References

Affected packages

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-arm64

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-arm64
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-arm64

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.29

Affected versions

5.*

5.0.0
5.0.1
5.0.2
5.0.3
5.0.4
5.0.5
5.0.6
5.0.7
5.0.8
5.0.9
5.0.10
5.0.11
5.0.12
5.0.13
5.0.14
5.0.15
5.0.16
5.0.17

6.*

6.0.0
6.0.1
6.0.2
6.0.3
6.0.4
6.0.5
6.0.6
6.0.7
6.0.8
6.0.9
6.0.10
6.0.11
6.0.12
6.0.13
6.0.14
6.0.15
6.0.16
6.0.18
6.0.19
6.0.20
6.0.21
6.0.22
6.0.23
6.0.24
6.0.25
6.0.26
6.0.27
6.0.28

Database specific

{
    "last_known_affected_version_range": "<= 6.0.28"
}

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-arm64

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-arm64
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-arm64

Affected ranges

Type
ECOSYSTEM
Events
Introduced
8.0.0
Fixed
8.0.4

Affected versions

8.*

8.0.0
8.0.1
8.0.2
8.0.3

Database specific

{
    "last_known_affected_version_range": "<= 8.0.3"
}

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-arm64

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-arm64
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-arm64

Affected ranges

Type
ECOSYSTEM
Events
Introduced
7.0.0
Fixed
7.0.18

Affected versions

7.*

7.0.0
7.0.1
7.0.2
7.0.3
7.0.4
7.0.5
7.0.7
7.0.8
7.0.9
7.0.10
7.0.11
7.0.12
7.0.13
7.0.14
7.0.15
7.0.16
7.0.17

Database specific

{
    "last_known_affected_version_range": "<= 7.0.17"
}

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-x64

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-x64
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-x64

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.29

Affected versions

3.*

3.0.0-preview7-27912-14
3.0.0-preview8-28405-07
3.0.0-preview9-19423-09
3.0.0-rc1-19456-20
3.0.0
3.0.1
3.0.2
3.0.3
3.1.0
3.1.1
3.1.2
3.1.3
3.1.4
3.1.5
3.1.6
3.1.7
3.1.8
3.1.9
3.1.10
3.1.11
3.1.12
3.1.13
3.1.14
3.1.15
3.1.16
3.1.17
3.1.18
3.1.19
3.1.20
3.1.21
3.1.22
3.1.23
3.1.24
3.1.25
3.1.26
3.1.27
3.1.28
3.1.29
3.1.30
3.1.31
3.1.32

5.*

5.0.0
5.0.1
5.0.2
5.0.3
5.0.4
5.0.5
5.0.6
5.0.7
5.0.8
5.0.9
5.0.10
5.0.11
5.0.12
5.0.13
5.0.14
5.0.15
5.0.16
5.0.17

6.*

6.0.0
6.0.1
6.0.2
6.0.3
6.0.4
6.0.5
6.0.6
6.0.7
6.0.8
6.0.9
6.0.10
6.0.11
6.0.12
6.0.13
6.0.14
6.0.15
6.0.16
6.0.18
6.0.19
6.0.20
6.0.21
6.0.22
6.0.23
6.0.24
6.0.25
6.0.26
6.0.27
6.0.28

Database specific

{
    "last_known_affected_version_range": "<= 6.0.28"
}

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-x64

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-x64
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-x64

Affected ranges

Type
ECOSYSTEM
Events
Introduced
8.0.0
Fixed
8.0.4

Affected versions

8.*

8.0.0
8.0.1
8.0.2
8.0.3

Database specific

{
    "last_known_affected_version_range": "<= 8.0.3"
}

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-x64

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-x64
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-x64

Affected ranges

Type
ECOSYSTEM
Events
Introduced
7.0.0
Fixed
7.0.18

Affected versions

7.*

7.0.0
7.0.1
7.0.2
7.0.3
7.0.4
7.0.5
7.0.7
7.0.8
7.0.9
7.0.10
7.0.11
7.0.12
7.0.13
7.0.14
7.0.15
7.0.16
7.0.17

Database specific

{
    "last_known_affected_version_range": "<= 7.0.17"
}

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-x86

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-x86
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-x86

Affected ranges

Type
ECOSYSTEM
Events
Introduced
7.0.0
Fixed
7.0.18

Affected versions

7.*

7.0.0
7.0.1
7.0.2
7.0.3
7.0.4
7.0.5
7.0.7
7.0.8
7.0.9
7.0.10
7.0.11
7.0.12
7.0.13
7.0.14
7.0.15
7.0.16
7.0.17

Database specific

{
    "last_known_affected_version_range": "<= 7.0.17"
}

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-x86

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-x86
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-x86

Affected ranges

Type
ECOSYSTEM
Events
Introduced
8.0.0
Fixed
8.0.4

Affected versions

8.*

8.0.0
8.0.1
8.0.2
8.0.3

Database specific

{
    "last_known_affected_version_range": "<= 8.0.3"
}

NuGet / Microsoft.WindowsDesktop.App.Runtime.win-x86

Package

Name
Microsoft.WindowsDesktop.App.Runtime.win-x86
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.WindowsDesktop.App.Runtime.win-x86

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.29

Affected versions

3.*

3.0.0-preview7-27912-14
3.0.0-preview8-28405-07
3.0.0-preview9-19423-09
3.0.0-rc1-19456-20
3.0.0
3.0.1
3.0.2
3.0.3
3.1.0
3.1.1
3.1.2
3.1.3
3.1.4
3.1.5
3.1.6
3.1.7
3.1.8
3.1.9
3.1.10
3.1.11
3.1.12
3.1.13
3.1.14
3.1.15
3.1.16
3.1.17
3.1.18
3.1.19
3.1.20
3.1.21
3.1.22
3.1.23
3.1.24
3.1.25
3.1.26
3.1.27
3.1.28
3.1.29
3.1.30
3.1.31
3.1.32

5.*

5.0.0
5.0.1
5.0.2
5.0.3
5.0.4
5.0.5
5.0.6
5.0.7
5.0.8
5.0.9
5.0.10
5.0.11
5.0.12
5.0.13
5.0.14
5.0.15
5.0.16
5.0.17

6.*

6.0.0
6.0.1
6.0.2
6.0.3
6.0.4
6.0.5
6.0.6
6.0.7
6.0.8
6.0.9
6.0.10
6.0.11
6.0.12
6.0.13
6.0.14
6.0.15
6.0.16
6.0.18
6.0.19
6.0.20
6.0.21
6.0.22
6.0.23
6.0.24
6.0.25
6.0.26
6.0.27
6.0.28

Database specific

{
    "last_known_affected_version_range": "<= 6.0.28"
}