GHSA-6vcc-v9vw-g2x5

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-6vcc-v9vw-g2x5/GHSA-6vcc-v9vw-g2x5.json
Aliases
  • CVE-2022-1993
Published
2022-06-08T22:34:23Z
Modified
2022-06-17T19:20:55Z
Details

Impact

The malicious user is able to craft HTTP requests to access unauthorized Git directories. All installations with are affected.

Patches

Path cleaning has accommodated for Git HTTP endpoints. Users should upgrade to 0.12.9 or the latest 0.13.0+dev.

Workarounds

N/A

References

https://huntr.dev/bounties/22f9c074-cf60-4c67-b5c4-72fdf312609d/

For more information

If you have any questions or comments about this advisory, please post on #7002.

References

Affected packages

Go / gogs.io/gogs

gogs.io/gogs

Affected ranges

Type
SEMVER
Events
Introduced
0
Fixed
0.12.9

Affected versions