GHSA-6x2w-gwgf-5rg3

Suggest an improvement
Source
https://github.com/advisories/GHSA-6x2w-gwgf-5rg3
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-6x2w-gwgf-5rg3/GHSA-6x2w-gwgf-5rg3.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-6x2w-gwgf-5rg3
Aliases
Published
2022-05-24T16:59:37Z
Modified
2024-02-16T07:56:50.049411Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Jenkins Deploy WebLogic Plugin cross-site request forgery vulnerability
Details

JenkinsDeploy WebLogic Plugin does not perform permission checks on a method implementing form validation. This allows users with Overall/Read access to Jenkins to send an HTTP HEAD request to a user-specified URL, or confirm the existence of any file or directory on the Jenkins controller.

Additionally, the form validation method does not require POST requests, resulting in a CSRF vulnerability.

As of publication of this advisory, there is no fix.

References

Affected packages

Maven / org.jenkins-ci.plugins:weblogic-deployer-plugin

Package

Name
org.jenkins-ci.plugins:weblogic-deployer-plugin
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/weblogic-deployer-plugin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
4.1

Affected versions

1.*

1.1
1.2
1.3
1.4

2.*

2.0
2.1
2.2
2.3
2.4
2.5
2.6
2.7
2.8
2.9
2.9.1
2.10
2.11
2.12
2.13

3.*

3.0
3.1
3.2
3.3
3.4
3.5
3.6
3.7

4.*

4.0
4.1