GHSA-6x4h-9622-fqr6

Suggest an improvement
Source
https://github.com/advisories/GHSA-6x4h-9622-fqr6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/12/GHSA-6x4h-9622-fqr6/GHSA-6x4h-9622-fqr6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-6x4h-9622-fqr6
Published
2023-12-13T13:35:16Z
Modified
2024-02-16T08:10:31.528429Z
Severity
  • 7.2 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Improper validation in meraki
Details

aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Improper validation made it possible for an attacker to modify the HTTP request (e.g. to insert a new header) or create a new HTTP request if the attacker controls the HTTP version. The vulnerability only occurs if the attacker can control the HTTP version of the request. This issue has been patched in version 3.9.0.

meraki from version 1.40.1 requires aiohttp 3.9.0

References

Affected packages

PyPI / meraki

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.40.1

Affected versions

0.*

0.1
0.11
0.13
0.14
0.15
0.16
0.17
0.18
0.19
0.20
0.21
0.22
0.24
0.25
0.26
0.27
0.28
0.29
0.30
0.31
0.32
0.33
0.34
0.70.1
0.70.2
0.70.3
0.70.4
0.70.5
0.80.0
0.80.1
0.80.2
0.80.3
0.90.0
0.90.1
0.90.2
0.100.0
0.100.1
0.100.2
0.110.0
0.110.1
0.110.2
0.110.3
0.110.4
0.110.5
0.110.6

1.*

1.0.0b1
1.0.0b2
1.0.0b3
1.0.0b4
1.0.0b5
1.0.0b6
1.0.0b7
1.0.0b8
1.0.0b9
1.0.0b10
1.0.0b11
1.0.0b12
1.0.0b13
1.0.0b14
1.0.0b15
1.0.0b17
1.0.0b18
1.0.0b19
1.0.0
1.1.0b1
1.1.0b2
1.1.0b3
1.1.0b4
1.1.0
1.2.0b1
1.2.0b2
1.2.0
1.3.0b1
1.3.0b2
1.3.0b3
1.3.0
1.4.0
1.4.1
1.4.2
1.4.3
1.6.0
1.6.1
1.6.2
1.7.0
1.7.1
1.7.2
1.10.0
1.12.0
1.15.0
1.18.0
1.18.1
1.18.2
1.19.0
1.20.0
1.22.0
1.22.1
1.24.0
1.25.0
1.27.0
1.30.0
1.32.0
1.32.1
1.33.0
1.34.0
1.36.0
1.37.1
1.37.2
1.37.3
1.38.0
1.39.0
1.39.1
1.40.0