GHSA-6x77-rpqf-j6mw

Suggest an improvement
Source
https://github.com/advisories/GHSA-6x77-rpqf-j6mw
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/03/GHSA-6x77-rpqf-j6mw/GHSA-6x77-rpqf-j6mw.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-6x77-rpqf-j6mw
Aliases
Published
2018-03-05T18:54:33Z
Modified
2023-11-08T03:58:43.801910Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
ejs vulnerable to DoS due to weak input validation
Details

nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in ejs.renderFile()

References

Affected packages

npm / ejs

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5.5