GHSA-72gm-pp6q-gpx5

Suggest an improvement
Source
https://github.com/advisories/GHSA-72gm-pp6q-gpx5
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-72gm-pp6q-gpx5/GHSA-72gm-pp6q-gpx5.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-72gm-pp6q-gpx5
Aliases
Published
2022-05-14T04:04:14Z
Modified
2024-02-16T08:19:52.986909Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
ChakraCore RCE Vulnerability
Details

ChakraCore and Microsoft Edge in Windows 10 1511, 1607, 1703, 1709, and Windows Server 2016 allows an attacker to execute arbitrary code in the context of the current user, due to how the scripting engine handles objects in memory, aka "Scripting Engine Memory Corruption Vulnerability". This CVE ID is unique from CVE-2017-11886, CVE-2017-11889, CVE-2017-11890, CVE-2017-11893, CVE-2017-11894, CVE-2017-11895, CVE-2017-11901, CVE-2017-11903, CVE-2017-11907, CVE-2017-11908, CVE-2017-11909, CVE-2017-11910, CVE-2017-11911, CVE-2017-11912, CVE-2017-11913, CVE-2017-11914, CVE-2017-11916, CVE-2017-11918, and CVE-2017-11930.

References

Affected packages

NuGet / Microsoft.ChakraCore

Package

Name
Microsoft.ChakraCore
View open source insights on deps.dev
Purl
pkg:nuget/Microsoft.ChakraCore

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.7.5

Affected versions

1.*

1.2.0
1.2.1
1.2.2
1.2.3
1.2.6.62716-preview
1.3.0
1.3.1
1.3.2
1.4.0
1.4.1
1.4.2
1.4.3
1.4.4
1.4.5
1.5.0
1.5.1
1.5.2
1.5.3
1.6.0
1.6.2
1.7.0
1.7.1
1.7.2
1.7.3
1.7.4