GHSA-72q2-5rxx-xfff

Suggest an improvement
Source
https://github.com/advisories/GHSA-72q2-5rxx-xfff
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2020/09/GHSA-72q2-5rxx-xfff/GHSA-72q2-5rxx-xfff.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-72q2-5rxx-xfff
Aliases
  • CVE-2017-16040
Published
2020-09-01T16:12:12Z
Modified
2023-11-08T03:59:01.120758Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
gfe-sass downloads Resources over HTTP
Details

Affected versions of gfe-sass insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running gfe-sass.

Recommendation

No patch is currently available for this vulnerability.

The best mitigation is currently to avoid using this package, using a different package if available.

Alternatively, the risk of exploitation can be reduced by ensuring that this package is not installed while connected to a public network. If the package is installed on a private network, the only people who can exploit this vulnerability are those who have compromised your network or those who have privileged access to your ISP, such as Nation State Actors or Rogue ISP Employees.

References

Affected packages

npm / gfe-sass

Package

Affected ranges

Type
SEMVER
Events
Introduced
0.0.0