GHSA-75w2-qv55-x7fv

Suggest an improvement
Source
https://github.com/advisories/GHSA-75w2-qv55-x7fv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/11/GHSA-75w2-qv55-x7fv/GHSA-75w2-qv55-x7fv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-75w2-qv55-x7fv
Aliases
  • CVE-2023-49210
Published
2023-11-23T21:30:18Z
Modified
2023-11-30T22:05:44Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
openssl npm package vulnerable to command execution
Details

The openssl (aka node-openssl) NPM package through 2.0.0 was characterized as "a nonsense wrapper with no real purpose" by its author, and accepts an opts argument that contains a verb field (used for command execution). NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

References

Affected packages

npm / openssl

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
2.0.0