GHSA-7752-f4gf-94gc

Suggest an improvement
Source
https://github.com/advisories/GHSA-7752-f4gf-94gc
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/04/GHSA-7752-f4gf-94gc/GHSA-7752-f4gf-94gc.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-7752-f4gf-94gc
Aliases
Published
2019-04-09T19:44:38Z
Modified
2023-11-08T04:00:59.129320Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Materialize-css vulnerable to Cross-site Scripting in autocomplete component
Details

All versions of materialize-css are vulnerable to Cross-Site Scripting. The autocomplete component does not sufficiently sanitize user input, allowing an attacker to execute arbitrary JavaScript code if the malicious input is rendered by a user.

Recommendation

No fix is currently available. Consider using an alternative module until a fix is made available.

References

Affected packages

npm / materialize-css

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.0.0

npm / @materializecss/materialize

Package

Name
@materializecss/materialize
View open source insights on deps.dev
Purl
pkg:npm/%40materializecss/materialize

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.0-alpha