GHSA-779c-7w4p-2c4g

Suggest an improvement
Source
https://github.com/advisories/GHSA-779c-7w4p-2c4g
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/05/GHSA-779c-7w4p-2c4g/GHSA-779c-7w4p-2c4g.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-779c-7w4p-2c4g
Published
2024-05-22T18:18:18Z
Modified
2024-05-22T18:58:29.043018Z
Severity
  • 3.8 (Low) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N CVSS Calculator
Summary
Silverstripe admin XSS Vulnerability via WYSIWYG editor
Details

It is possible for a bad actor with access to the CMS to make use of onmouseover or onmouseout attributes in the WYSIWYG editor to embed malicious javascript.

References

Affected packages

Packagist / silverstripe/admin

Package

Name
silverstripe/admin
Purl
pkg:composer/silverstripe/admin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.3
Fixed
1.0.4

Affected versions

1.*

1.0.3

Packagist / silverstripe/admin

Package

Name
silverstripe/admin
Purl
pkg:composer/silverstripe/admin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.1.0
Fixed
1.1.1

Affected versions

1.*

1.1.0