GHSA-77pw-c3j2-5fc8

Suggest an improvement
Source
https://github.com/advisories/GHSA-77pw-c3j2-5fc8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/04/GHSA-77pw-c3j2-5fc8/GHSA-77pw-c3j2-5fc8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-77pw-c3j2-5fc8
Aliases
Published
2021-04-30T17:34:03Z
Modified
2024-02-16T08:19:44.216240Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N CVSS Calculator
Summary
Plaintext password leak in Apache Superset
Details

In the course of work on the open source project it was discovered that authenticated users running queries against Hive and Presto database engines could access information via a number of templated fields including the contents of query description metadata database, the hashed version of the authenticated users’ password, and access to connection information including the plaintext password for the current connection. It would also be possible to run arbitrary methods on the database connection object for the Presto or Hive connection, allowing the user to bypass security controls internal to Superset. This vulnerability is present in every Apache Superset version < 0.37.2.

References

Affected packages

PyPI / apache-superset

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.37.2

Affected versions

0.*

0.34.0
0.34.1
0.35.1
0.35.2
0.36.0
0.37.0
0.37.1