GHSA-78h3-pg4x-j8cv

Suggest an improvement
Source
https://github.com/advisories/GHSA-78h3-pg4x-j8cv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/05/GHSA-78h3-pg4x-j8cv/GHSA-78h3-pg4x-j8cv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-78h3-pg4x-j8cv
Aliases
  • CVE-2024-34394
Published
2024-05-02T21:30:29Z
Modified
2024-05-03T20:43:33.331355Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
libxmljs vulnerable to type confusion when parsing specially crafted XML
Details

libxmljs2 is vulnerable to a type confusion vulnerability when parsing a specially crafted XML while invoking the namespaces() function (which invokes XmlNode::get_local_namespaces()) on a grand-child of a node that refers to an entity. This vulnerability can lead to denial of service and remote code execution.

References

Affected packages

npm / libxmljs2

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.0.11