GHSA-798p-53r7-mgw9

Suggest an improvement
Source
https://github.com/advisories/GHSA-798p-53r7-mgw9
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-798p-53r7-mgw9/GHSA-798p-53r7-mgw9.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-798p-53r7-mgw9
Aliases
Published
2022-05-13T01:18:46Z
Modified
2023-11-08T03:59:38.587946Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Jenkins HipChat Plugin allows attackers with Overall/Read access to obtain credential IDs
Details

An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and earlier in HipChatNotifier.java that allows attackers with Overall/Read access to obtain credentials IDs for credentials stored in Jenkins. As of version 2.2.1, an enumeration of credentials IDs in this plugin requires Overall/Administer permission.

References

Affected packages

Maven / org.jvnet.hudson.plugins:hipchat

Package

Name
org.jvnet.hudson.plugins:hipchat
View open source insights on deps.dev
Purl
pkg:maven/org.jvnet.hudson.plugins/hipchat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.1

Affected versions

0.*

0.1.1
0.1.3
0.1.4
0.1.5
0.1.6
0.1.7
0.1.8
0.1.9
0.2.0

1.*

1.0.0

2.*

2.0.0
2.1.0
2.1.1
2.2.0