GHSA-79rm-f26g-296p

Suggest an improvement
Source
https://github.com/advisories/GHSA-79rm-f26g-296p
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-79rm-f26g-296p/GHSA-79rm-f26g-296p.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-79rm-f26g-296p
Aliases
  • CVE-2019-10360
Published
2022-05-24T16:51:51Z
Modified
2024-02-16T08:16:19.138944Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Jenkins Maven Release Plugin vulnerable to Cross-site Scripting
Details

A stored cross site scripting vulnerability in Jenkins Maven Release Plugin 0.14.0 and earlier allowed attackers to inject arbitrary HTML and JavaScript in the plugin-provided web pages in Jenkins.

Variables on affected views are now escaped.

References

Affected packages

Maven / org.jenkins-ci.plugins.m2release:m2release

Package

Name
org.jenkins-ci.plugins.m2release:m2release
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins.m2release/m2release

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.15.0

Affected versions

0.*

0.11.0
0.12.0
0.13.0
0.14.0