GHSA-79x9-477g-w256

Suggest an improvement
Source
https://github.com/advisories/GHSA-79x9-477g-w256
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-79x9-477g-w256/GHSA-79x9-477g-w256.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-79x9-477g-w256
Aliases
  • CVE-2022-36918
Published
2022-07-28T00:00:42Z
Modified
2024-02-16T08:20:41.136436Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins Buckminster Plugin does not perform a permission check in a method implementing form validation
Details

Jenkins Buckminster Plugin 1.1.1 and earlier does not perform a permission check in a method implementing form validation.

This allows attackers with Overall/Read permission to check for the existence of an attacker-specified file path on the Jenkins controller file system. A sequence of requests can be used to effectively list the Jenkins controller file system.

As of publication of this advisory, there is no fix.

References

Affected packages

Maven / org.jenkins-ci.plugins:buckminster

Package

Name
org.jenkins-ci.plugins:buckminster
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/buckminster

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.1.1

Affected versions

1.*

1.1.1