GHSA-7ff4-cv53-4cjq

Suggest an improvement
Source
https://github.com/advisories/GHSA-7ff4-cv53-4cjq
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-7ff4-cv53-4cjq/GHSA-7ff4-cv53-4cjq.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-7ff4-cv53-4cjq
Aliases
Published
2022-05-24T17:30:27Z
Modified
2024-04-24T17:28:13.736291Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
phpMyAdmin SQL injection vulnerability
Details

An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.

References

Affected packages

Packagist / phpmyadmin/phpmyadmin

Package

Name
phpmyadmin/phpmyadmin
Purl
pkg:composer/phpmyadmin/phpmyadmin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.9.0
Fixed
4.9.6

Affected versions

4.*

4.9.0
4.9.0.1
4.9.1
4.9.2
4.9.3
4.9.4
4.9.5

Packagist / phpmyadmin/phpmyadmin

Package

Name
phpmyadmin/phpmyadmin
Purl
pkg:composer/phpmyadmin/phpmyadmin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.0.0
Fixed
5.0.3

Affected versions

5.*

5.0.0
5.0.0.1
5.0.1
5.0.2