GHSA-7fjv-25q9-2w88

Source
https://github.com/advisories/GHSA-7fjv-25q9-2w88
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/05/GHSA-7fjv-25q9-2w88/GHSA-7fjv-25q9-2w88.json
Published
2024-05-15T22:26:19Z
Modified
2024-05-15T22:31:17.546806Z
Summary
State Guessing Vulnerability in laravel/socialite
Details

laravel/socialite versions prior to 2.0.10 are susceptible to a security vulnerability related to state guessing during OAuth authentication. This vulnerability could potentially lead to session hijacking, allowing attackers to compromise user sessions. The issue has been addressed and fixed in version 2.0.10.

References

Affected packages

Packagist / laravel/socialite

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.0
Fixed
2.0.10

Affected versions

v1.*

v1.0.0
v1.0.1
v1.0.2
v1.0.3

v2.*

v2.0.0
v2.0.1
v2.0.2
v2.0.3
v2.0.4
v2.0.5
v2.0.6
v2.0.7
v2.0.8
v2.0.9