GHSA-7h42-5vj2-cq39

Suggest an improvement
Source
https://github.com/advisories/GHSA-7h42-5vj2-cq39
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/03/GHSA-7h42-5vj2-cq39/GHSA-7h42-5vj2-cq39.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-7h42-5vj2-cq39
Aliases
Published
2018-03-13T20:42:00Z
Modified
2023-11-08T03:59:34.526312Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
tiny-json-http missing SSL certificate validation
Details

brianleroux tiny-json-http version all versions since commit 9b8e74a232bba4701844e07bcba794173b0238a8 (Oct 29 2016) contains a Missing SSL certificate validation vulnerability in The libraries core functionality is affected. that can result in Exposes the user to man-in-the-middle attacks.

References

Affected packages

npm / tiny-json-http

Package

Affected ranges

Type
SEMVER
Events
Introduced
1.0.1
Fixed
7.0.0