GHSA-7h99-vjmf-5pg8

Suggest an improvement
Source
https://github.com/advisories/GHSA-7h99-vjmf-5pg8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-7h99-vjmf-5pg8/GHSA-7h99-vjmf-5pg8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-7h99-vjmf-5pg8
Aliases
  • CVE-2019-1003068
Published
2022-05-13T01:17:44Z
Modified
2024-02-16T08:11:06.941553Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins VMware vRealize Automation Plugin Missing Encryption of Sensitive Data
Details

Jenkins VMware vRealize Automation Plugin stores credentials unencrypted in job config.xml files on the Jenkins controller. These credentials can be viewed by users with Extended Read permission, or access to the Jenkins controller file system.

References

Affected packages

Maven / com.inkysea.vmware.vra:vmware-vrealize-automation-plugin

Package

Name
com.inkysea.vmware.vra:vmware-vrealize-automation-plugin
View open source insights on deps.dev
Purl
pkg:maven/com.inkysea.vmware.vra/vmware-vrealize-automation-plugin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.2.3

Affected versions

1.*

1.0
1.0.1
1.1
1.1.1
1.2
1.2.1
1.2.2
1.2.3