GHSA-7p4p-v6hr-gp3m

Suggest an improvement
Source
https://github.com/advisories/GHSA-7p4p-v6hr-gp3m
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-7p4p-v6hr-gp3m/GHSA-7p4p-v6hr-gp3m.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-7p4p-v6hr-gp3m
Aliases
Published
2022-05-14T03:13:12Z
Modified
2024-02-16T08:23:50.521563Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Jenkins Gitlab Hook Plugin stores and displays GitLab API token in plain text
Details

A exposure of sensitive information vulnerability exists in Jenkins Gitlab Hook Plugin 1.4.2 and older in gitlabnotifier.rb, views/gitlabnotifier/global.erb that allows attackers with local Jenkins master file system access or control of a Jenkins administrator's web browser (e.g. malicious extension) to retrieve the configured Gitlab token.

References

Affected packages

Maven / org.jenkins-ci.ruby-plugins:gitlab-hook

Package

Name
org.jenkins-ci.ruby-plugins:gitlab-hook
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.ruby-plugins/gitlab-hook

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.4.2

Affected versions

0.*

0.1.0
0.1.1
0.2.0
0.2.1
0.2.2
0.2.3
0.2.4
0.2.5
0.2.6
0.2.7
0.2.8
0.2.9
0.2.10
0.2.11
0.2.12

1.*

1.0.0
1.1.0
1.2.0
1.2.1
1.3.0
1.3.1
1.4.0
1.4.1
1.4.1.1
1.4.2