GHSA-7qq9-9g2w-56f9

Suggest an improvement
Source
https://github.com/advisories/GHSA-7qq9-9g2w-56f9
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/08/GHSA-7qq9-9g2w-56f9/GHSA-7qq9-9g2w-56f9.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-7qq9-9g2w-56f9
Aliases
Published
2022-08-20T00:00:30Z
Modified
2024-02-17T05:36:58.372049Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Improper Privilege Management in com.xuxueli:xxl-job
Details

XXL-JOB all versions as of 11 July 2022 are vulnerable to Insecure Permissions resulting in the ability to execute admin function with low Privilege account.

References

Affected packages

Maven / com.xuxueli:xxl-job

Package

Name
com.xuxueli:xxl-job
View open source insights on deps.dev
Purl
pkg:maven/com.xuxueli/xxl-job

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.0

Affected versions

1.*

1.4.1
1.4.2
1.5.0
1.5.1
1.5.2
1.6.0
1.6.1
1.6.2
1.7.0
1.7.1
1.7.2
1.8.0
1.8.1
1.8.2
1.9.0
1.9.1
1.9.2

2.*

2.0.0
2.0.1
2.0.2
2.1.0
2.1.1
2.1.2
2.2.0
2.3.0
2.3.1

Database specific

{
    "last_known_affected_version_range": "<= 2.3.1"
}