GHSA-833m-37f7-jq55

Source
https://github.com/advisories/GHSA-833m-37f7-jq55
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/02/GHSA-833m-37f7-jq55/GHSA-833m-37f7-jq55.json
Aliases
Published
2024-02-08T18:46:23Z
Modified
2024-02-15T21:41:44.734408Z
Details

Impact

A vulnerability has been identified in which unauthenticated cross-site scripting (XSS) in the API Server's public API endpoint can be exploited. This can lead to an attacker exploiting the vulnerability to trigger JavaScript code and execute commands remotely.

The attack vector was identified as a Reflected XSS.

API Server propagates malicious payloads from user input to the UI, which renders the output. For example, a malicious URL gets rendered into a script that is executed on a page.

The changes addressed by this fix are: - Encode input that comes from the request URL before adding it to the response. - The request input is escaped by changing the URL construction that is used for links to use url.URL. - The request input is escaped by escaping the JavaScript and CSS variables with attribute encoding as defined by OWASP.

Patches

Patched versions include the following commits:

| Branch | Commit | | -------- | ------- | | master | 4fd7d82 | | release/v2.8 | 69b3c2b | | release/v2.8.s3 | a3b9e37 | | release/v2.7 | 4e102cf | | release/v2.7.s3 | 97a10a3 | | release/v2.6 | 4df268e |

Workarounds

There is no direct mitigation besides updating API Server to a patched version.

References

If you have any questions or comments about this advisory:

References

Affected packages

Go / github.com/rancher/apiserver

Affected ranges

Type
SEMVER
Events
Introduced
0The exact introduced commit is unknown
Fixed
0.0.0-20240207153957-4fd7d821d952