GHSA-837v-6vgx-jqcc

Suggest an improvement
Source
https://github.com/advisories/GHSA-837v-6vgx-jqcc
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/12/GHSA-837v-6vgx-jqcc/GHSA-837v-6vgx-jqcc.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-837v-6vgx-jqcc
Aliases
Published
2022-12-12T15:30:31Z
Modified
2023-11-08T04:07:06.271884Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
yikes-inc-easy-mailchimp-extender Cross-site Scripting vulnerability
Details

A vulnerability classified as problematic has been found in yikes-inc-easy-mailchimp-extender Plugin up to 6.8.5. This affects an unknown part of the file admin/partials/ajax/addfieldtoform.php. The manipulation of the argument fieldname/mergetag/fieldtype/list_id leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 6.8.6 can address this issue. The name of the patch is 3662c6593aa1bb4286781214891d26de2e947695. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215307.

References

Affected packages

Packagist / yikesinc/yikes-inc-easy-mailchimp-extender

Package

Name
yikesinc/yikes-inc-easy-mailchimp-extender
Purl
pkg:composer/yikesinc/yikes-inc-easy-mailchimp-extender

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.8.6

Affected versions

5.*

5.1
5.1.0.1
5.1.1
5.4.3

6.*

6.0.0-rc1.0
6.0.2.2
6.0.2.4
6.0.3.2
6.0.3.3
6.0.3.6
6.0.3.7
6.0.3.8
6.0.3.9
6.0.5.3
6.6.0
6.6.1
6.6.2
6.6.3
6.6.4
6.8.0
6.8.1
6.8.2
6.8.3
6.8.4
6.8.5

v6.*

v6.0.1
v6.0.3
v6.0.5
v6.1
v6.1.1
v6.1.2
v6.1.3
v6.1.4
v6.2.0
v6.2.1
v6.5.5
v6.7.0