GHSA-84pr-m4jr-85g5

Suggest an improvement
Source
https://github.com/advisories/GHSA-84pr-m4jr-85g5
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/04/GHSA-84pr-m4jr-85g5/GHSA-84pr-m4jr-85g5.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-84pr-m4jr-85g5
Aliases
  • CVE-2024-1681
Published
2024-04-19T21:31:08Z
Modified
2024-05-07T13:31:00.917496Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N CVSS Calculator
Summary
flask-cors vulnerable to log injection when the log level is set to debug
Details

corydolphin/flask-cors is vulnerable to log injection when the log level is set to debug. An attacker can inject fake log entries into the log file by sending a specially crafted GET request containing a CRLF sequence in the request path. This vulnerability allows attackers to corrupt log files, potentially covering tracks of other attacks, confusing log post-processing tools, and forging log entries. The issue is due to improper output neutralization for logs.

References

Affected packages

PyPI / flask-cors

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0.1

Affected versions

1.*

1.0
1.1
1.1.1
1.1.2
1.1.3
1.2.0
1.2.1
1.3.0
1.3.1
1.4.0
1.5.0
1.6.0
1.6.1
1.7.0
1.7.1
1.7.2
1.7.3
1.7.4
1.8.0
1.8.1
1.9.0
1.10.0
1.10.1
1.10.2
1.10.3

2.*

2.0.0rc1
2.0.0
2.0.1
2.1.0
2.1.1
2.1.2
2.1.3

3.*

3.0.0
3.0.1
3.0.2
3.0.3
3.0.4
3.0.6
3.0.7
3.0.8
3.0.9
3.0.10

4.*

4.0.0a0
4.0.0

Database specific

{
    "last_known_affected_version_range": "<= 4.0.0"
}