GHSA-8699-h45g-7hm8

Suggest an improvement
Source
https://github.com/advisories/GHSA-8699-h45g-7hm8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/07/GHSA-8699-h45g-7hm8/GHSA-8699-h45g-7hm8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-8699-h45g-7hm8
Aliases
Published
2023-07-06T19:24:04Z
Modified
2024-02-16T08:08:41.681429Z
Severity
  • 4.8 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Concrete CMS Cross-site Scripting vulnerability
Details

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Stored Cross-Site Scripting (XSS) in dashboard/system/express/entities/associations because Concrete CMS allows association with an entity name that doesn’t exist or, if it does exist, contains XSS since it was not properly sanitized. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

References

Affected packages

Packagist / concrete5/concrete5

Package

Name
concrete5/concrete5
Purl
pkg:composer/concrete5/concrete5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.5.10

Affected versions

8.*

8.0
8.0.1
8.0.2
8.0.3
8.1.0
8.2.0RC2
8.2.0
8.2.1
8.3.0
8.3.1
8.3.2
8.4.0RC3
8.4.0RC4
8.4.0
8.4.1
8.4.2
8.4.3
8.4.4
8.4.5
8.5.0RC1
8.5.0RC2
8.5.0
8.5.1
8.5.2
8.5.3
8.5.4
8.5.5
8.5.6RC1
8.5.6
8.5.7
8.5.8
8.5.9

Packagist / concrete5/concrete5

Package

Name
concrete5/concrete5
Purl
pkg:composer/concrete5/concrete5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
9.0.0
Fixed
9.1.3

Affected versions

9.*

9.0.0
9.0.1
9.0.2
9.1.0
9.1.1
9.1.2